Next Matter

Intermittent issues with Microsoft integrations
Resolved·Degraded performance

This issue is now resolved. All integrations with Microsoft products and APIs are fully operational.

Mon, Jun 30, 2025, 10:24 AM
(3 months ago)
·
Affected components
Updates

Resolved

This issue is now resolved. All integrations with Microsoft products and APIs are fully operational.

Mon, Jun 30, 2025, 10:24 AM

Monitoring

A fix has been deployed to our production systems, and we are monitoring the status of integrations with Microsoft services and APIs.

Mon, Jun 30, 2025, 10:11 AM(12 minutes earlier)

Identified

Our team has identified the issue, and a fix is being deployed to our production systems.

Mon, Jun 30, 2025, 09:59 AM(12 minutes earlier)

Investigating

We are currently experiencing intermittent issues with Microsoft integrations, including Outlook, Excel, and SharePoint. Our team is investigating. We will provide updates as soon as possible.

Mon, Jun 30, 2025, 08:10 AM(1 hour earlier)