Back to overview
Downtime

Next Matter Help Centre unavailable

Mar 26 at 04:34pm UTC
Affected services
Customer Support Website

Resolved
Mar 26 at 04:45pm UTC

The issue affecting our Help Centre has been resolved and the service is available again.

Created
Mar 26 at 04:34pm UTC

Our Help Centre at help.nextmatter.com is currently unavailable due to a major outage at a 3rd party provider hosting the content.