Back to overview
Degraded

Increased response and load times

Nov 24 at 01:23pm UTC
Affected services
Next Matter Application
Next Matter API

Resolved
Nov 24 at 03:48pm UTC

We have deployed changes to our services, and API response latency and application load times have recovered to normal levels. We are continuing to monitor the situation.

Created
Nov 24 at 01:23pm UTC

We are currently investigating increased response times from our API services, and increased load times off our web application. Both services remain operational, however may provide a degraded user experience.